Plataforma de Atendimento Humano - Tech4Humans
Incident Report for D1
Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 11:00 GMT-03:00
Investigating
We are currently investigating this issue.
Posted Nov 16, 2021 - 10:28 GMT-03:00
This incident affected: Plataforma de Atendimento Humano - Tech4Humans.